Blog do programador e tecnico em redes ….

Categoria — Redes

Flash ActionScript 3 API for Mikrotik RouterOS

O MikroTik, além de configuração de Apoio sobre Telnet / SSH / telnet-MAC. possui um chamado RouterOS API.

Através da API que você puder ler informações, configuração definidas e até mesmo eventos. Por exemplo, a lista a todos os usuários conectados dBm WLAN.

A API é “literatura aberta” e você está convidado a criar diferentes idiomas e bibliotecas para postar em seu site. Eles já têm PHP, Ruby, Perl, Java, implementações, etc, objetivo que eu queria ser capaz de criar um aplicativo do AIR do Flash para exibir e configurar roteadores. Então, eu criei um Flash ActionScript 3 classe para isso.

Abaixo uma classe ActionScript para acesso a API do MikroTik:


// ApiSocket.as
// RouterOS API class
// Author: Haikon Nessjore

package {

import flash.errors.*;
import flash.events.*;
import flash.utils.ByteArray;
import com.adobe.crypto.MD5;
import flash.net.Socket;

public class ApiSocket extends Socket {
static public var RECEIVED:String = "received";
static public var LOGIN:String = "loggedin";
private var cmd:String;
private var doLogin:int;
private var user:String;
private var password:String;
private var returnData:Array;
private var returnPos:int;
private var toread:int;
private var firstRe:int;
private var tag:String;
private var gotDone:Boolean;
private var gotTrap:Boolean;
private var gotFatal:Boolean;

public function ApiSocket(host:String, port:uint) {
super(host, port);
toread = 0;
doLogin = 0;
addEventListener(ProgressEvent.SOCKET_DATA, socketDataHandler);
}

public function login(u:String, p:String) {
doLogin = 1;
user = u;
password = p;
sendRequest("/login");
}

public function sendRequest(... outData):void {
returnData = new Array();
returnPos = 0;
firstRe = 0;
gotDone = false;
gotTrap = false;
gotFatal = false;
tag = "";
cmd = outData[0];
returnData[returnPos] = new Object();

for (var i:int = 0; i < outData.length; ++i) {
var data:ByteArray = new ByteArray();

var len:uint = outData[i].length;

if (len < 0x80)
data.writeByte(len);
else
if (len < 0x4000) {
len |= 0x8000;
data.writeByte(( len >> 8 ) & 0xff);
data.writeByte(len & 0xff);
} else
if (len < 0x200000) {
len |= 0xC00000;
data.writeByte(( len >> 16 ) & 0xff);
data.writeByte(( len >> 8 ) & 0xff);
data.writeByte(len & 0xff);
} else
if (len < 0x10000000) {
len |= 0xE0000000;
data.writeByte(( len >> 24 ) & 0xff);
data.writeByte(( len >> 16 ) & 0xff);
data.writeByte(( len >> 8 ) & 0xff);
data.writeByte( len & 0xff );
} else {
data.writeByte(0xF0);
data.writeByte(( len >> 24 ) & 0xff);
data.writeByte(( len >> 16 ) & 0xff);
data.writeByte(( len >> 8 ) & 0xff);
data.writeByte( len & 0xff );
}

writeBytes(data);
writeUTFBytes(outData[i]);
}
writeByte(0);
flush();
}

private function readResponse():void {
var len:int;

if (toread == 0) {
var len1:uint = readUnsignedByte();

if (len1 == 0) {
if (gotDone || gotTrap || gotFatal) {
if (doLogin == 1) {
if (returnData[0].ret) {
var chal:ByteArray = new ByteArray();
var md5:ByteArray = new ByteArray();

for (var i:int = 0; i < returnData[0].ret.length; i += 2) {
chal.writeByte(int("0x" + returnData[0].ret.substr(i,2)));
}

md5.writeByte(0);
md5.writeUTFBytes(password);
md5.writeBytes(chal);

doLogin++;
// Send challenge response
sendRequest("/login", "=name=" + user, "=response=00" + MD5.hashBytes(md5));
}
} else if (doLogin == 2) {
doLogin = 0;
dispatchEvent(new ApiEvent(ApiSocket.LOGIN, "", returnData, gotDone ? 'done' : (gotFatal ? 'fatal' : 'trap')));
} else {
dispatchEvent(new ApiEvent(ApiSocket.RECEIVED, tag, returnData, gotDone ? 'done' : (gotFatal ? 'fatal' : 'trap')));
}
}

if (bytesAvailable)
readResponse();
else
return;
}

if (len1 >= 0xF0) {
len = readUnsignedByte();
len = ( len << 8 ) + readUnsignedByte();
len = ( len << 8 ) + readUnsignedByte();
len = ( len << 8 ) + readUnsignedByte();
} else
if (len1 >= 0xE0) {
len = (( len1 & 15 ) << 8 ) + readUnsignedByte();
len = ( len << 8 ) + readUnsignedByte();
len = ( len << 8 ) + readUnsignedByte();
} else
if (len1 >= 0xC0) {
len = (( len1 & 31 ) << 8 ) + readUnsignedByte();
len = ( len << 8 ) + readUnsignedByte();
} else
if (len1 >= 0x80) {
len = (( len1 & 63 ) << 8 ) + readUnsignedByte();
} else
len = len1;

toread = len;
}

// Calculate how much data of the full length that is available right now
var slen:int = bytesAvailable > toread ? toread : bytesAvailable;
// Calculate how much data that has to be read later
toread = toread > bytesAvailable ? toread - bytesAvailable : 0;

// Read relevant data
var str:String = readUTFBytes(slen);

if (toread == 0) {
if (str == '!re') {
firstRe++;
if (firstRe > 1) {
returnPos++
returnData[returnPos] = new Object();
}
}
if (str == '!trap')
gotTrap = true;

if (str == '!fatal')
gotFatal = true;

if (str == '!done')
gotDone = true;

// Parse key-value pair
if (str.substr(0,1) == '=') {
var tmpPos:int = str.indexOf('=',1);
var tmpKey:String = str.substr(1,tmpPos-1);
var tmpVal:String = str.substr(tmpPos+1);
returnData[returnPos][tmpKey] = tmpVal;
}

// Reset tag
if (str.substr(0,1) == '!')
tag = "";

// Set tag
if (str.substr(0,5) == '.tag=')
tag = str.substr(5);

// Are there more packets available
if (bytesAvailable)
readResponse();
}

}

private function socketDataHandler(event:ProgressEvent):void {
readResponse();
}
}
}

// ApiEvent.as
//
// RouterOS API Event class
// Author: Håkon Nessjøen
// Date: 2. May 2009
//
package {

import flash.events.Event;

public class ApiEvent extends Event {
static public var RECEIVED:String = "received";
static public var LOGIN:String = "loggedin";

public var data:Array;
public var result:String;
public var tag:String;

public function ApiEvent(type:String, tg:String, dta:Array, res:String){
super(type);
data = dta;
result = res;
tag = tg;
}
}

}

12 / abril / 2012   Sem Comentarios

configurar load balance PCC no MikroTik

ESTRUTURA:

LAN: 10.0.0.0/27
ISP1: 192.168.0.0/27
ISP2: 192.168.3.0/24

ENDERECOS:

/ip address
add address=10.0.0.1/27 broadcast=10.0.0.31 comment=”" disabled=no interface=LAN network=10.0.0.0

add address=192.168.0.10/27 broadcast=192.168.0.31 comment=”" disabled=no interface=ISP1 network=192.168.0.0

add address=192.168.3.1/24 broadcast=192.168.3.255 comment=”" disabled=no interface=ISP2 network=192.168.3.0

ROTAS:

/ip route
add check-gateway=ping comment=”Rota Saida GVT para Load Balance” disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.3.20 routing-mark=ISP2_traffic scope=30 target-scope=10

add check-gateway=ping comment=”Rota saida Velox para Load Balance” disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.0.1 routing-mark=ISP1_traffic scope=30 target-scope=10

add check-gateway=ping comment=”Rota saida Velox/GVT sem Load Balance” disabled=no distance=2 dst-address=0.0.0.0/0 gateway=192.168.0.1,192.168.3.20 scope=30 target-scope=10

NAT:

/ip firewall nat
add action=masquerade chain=srcnat comment=”" disabled=no out-interface=ISP1

add action=masquerade chain=srcnat comment=”" disabled=no out-interface=ISP2

MANGLE:

/ip firewall mangle
add action=mark-connection chain=input comment=”Marca Conexoes de entrada para que voltem pelo mesmo link” disabled=no in-interface=ISP1 new-connection-mark=ISP1_conn passthrough=yes

add action=mark-connection chain=input comment=”" disabled=no in-interface=ISP2 new-connection-mark=ISP2_conn passthrough=yes

add action=mark-connection chain=output comment=”Inicia o balance” connection-state=new disabled=no dst-address=!10.0.0.0/27 new-connection-mark=ISP1_conn passthrough=yes per-connection-classifier=both-addresses:2/0

add action=mark-connection chain=output comment=”" connection-state=new disabled=no dst-address=!10.0.0.0/27 new-connection-mark=ISP2_conn passthrough=yes per-connection-classifier=both-addresses:2/1

add action=mark-routing chain=output comment=”Retorna as conexoes marcadas no inicio, pelo mesmo link que entraram” connection-mark=ISP1_conn disabled=no new-routing-mark=ISP1_traffic passthrough=yes

add action=mark-routing chain=output comment=”" connection-mark=ISP2_conn disabled=no new-routing-mark=ISP2_traffic passthrough=yes

add action=mark-connection chain=prerouting comment=”Load Balance (PCC)” disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=ISP1_conn passthrough=yes per-connection-classifier=both-addresses:2/0

add action=mark-connection chain=prerouting comment=”" disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=ISP2_conn passthrough=yes per-connection-classifier=both-addresses:2/1

add action=mark-routing chain=prerouting comment=”Conexoes do load balance para as novas tabelas do PCC” connection-mark=ISP1_conn disabled=no in-interface=LAN new-routing-mark=ISP1_traffic passthrough=yes

add action=mark-routing chain=prerouting comment=”" connection-mark=ISP2_conn disabled=no in-interface=LAN new-routing-mark=ISP2_traffic passthrough=yes

23 / maio / 2011   Sem Comentarios

Endereços IP’S com violação da RFC1918 e mascaras de rede incorretas

Vejo hoje muitos provedores utilizando faixas de ip que não são reservadas para redes internas, e isso é um erro pois a internet é constituida por endereços IP versão 4, quatro sequencias decimais de 0 a 255 são usadas para isso. Acontece que para haver comunicação numa rede cada computador deve possuir um endereço único, como o número de computadores é muito superior a de endereços válidos disponíveis, foram reservados faixas para uso privado livre, estes endereços, listados abaixo, não estão autorizados a trafegar na internet e para isso é necessário empregar NAT para que computadores com estes ips:

169.254.0.0/16
192.168.0.0/16
10.0.0.0/8
172.16.0.0/16

Usar ips fora da faixa RFC1918 resulta nos seguintes problemas:
- Se você colocar o ip 40.40.40.40 em um computador na rede local, este computadores estará usando um ip de algum servidor existente na internet, logo o site ou serviço que use este ip na internet não poderá ser acessado.
- Softwares de servidores, roteadores, access points são projetados obedecendo as regras internacionais (RFC’s), infringí-las pode resultar em mal funcionamento envolvendo estes equipamentos.

Outra coisa que observo sempre é duvidas a respeito de mascaras de rede, e coloquei abaixo uma lista de quantos hosts cada rede pode ter com determinada mascara:

mascara – numero de hosts
8/255.0.0.0 – 16.777.216
16/255.255.0.0 – 65.536
20/255.255.240.0 – 4096
21/255.255.248.0 – 2048
22/255.255.252.0 – 1028
23/255.255.254.0 – 512
24/255.255.255.0 – 256
25/255.255.255.128 – 128
26/255.255.255.192 – 64
27/255.255.255.224 – 32
28/255.255.255.240 – 16
29/255.255.255.248 – 8
30/255.255.255.252 – 4
31/255.255.255.254 – 2
32/255.255.255.255 – 1

Fica ai a dica ….

14 / novembro / 2009   Sem Comentarios